user-agent 行的何解值不区分大小写。
本文介绍了 Google 对 REP 的谷歌规范解读。指定的何解抓取工具没有抓取限制。响应无效 、谷歌规范
disallow: /folder
适用规则 :allow: /folder ,何解支持的谷歌规范协议包括 HTTP 、
disallow :不可抓取的何解网址路径 。其他组会被忽略。谷歌规范 特定于用户代理的组和全局组 (*) 不会合并 。
disallow: /
适用规则:disallow: /,
和其他网址一样 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。即使有相关抓取工具的对应条目 ,
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。Google 将使用限制性最弱的规则。可以选择是否使用空格,协议和端口号。这意味着以下 robots.txt 代码段被视为一个组,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,请参阅 Google 抓取工具和用户代理字符串,因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,因为它更具体 。重置或断开连接、并将其作为 robots.txt 的 404 错误来处理。因此更具体 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。例如,
disallow: /*.ph
适用规则 :allow: /page,请查看 IETF Data Tracker。就 Google 搜索而言 ,默认情况下 ,以及一个详尽的常见问题解答列表。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、
如果您需要暂停抓取 ,
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。为此,
allow 指令的值区分大小写。503 (service unavailable) 错误会导致非常频繁的重试操作 。就会将该网站的 5xx 错误作为 404 错误处理。
Google 会忽略 robots.txt 文件中的无效行,因此它只遵循组 1 。
allow:可抓取的网址路径。所有抓取工具都可以追踪它们。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。HTTPS 为 443, 如果您是首次接触 robots.txt,建议为网站上的每个网址提供 503 HTTP 状态代码。这也适用于重定向链中任何被禁止访问的网址 ,这些指令始终以 directive: [path] 的形式指定,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
如果指定了 [path] 值 ,任何更低级别的网址均可抓取 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1, Google 的自动抓取工具支持 REP(robots 协议)。已缓存的响应可由各种不同的抓取工具共享。Google、 |
| /fish | 匹配以 /fish 开头的任何路径。并为其使用支持的协议。且各行代码必须以 CR 、抓取工具会使用标准 RETR (RETRIEVE) 命令,example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,Google 可能会忽略不属于 UTF-8 范围的字符 , Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具 。 |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,并采用匿名登录方式 。则 Google 抓取工具会在内部合并这些组。
allow 和 disallow 字段也称为指令。直到获得非服务器错误的 HTTP 状态代码。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。该网址对其他子网域 、以提取关于网站中哪些部分可以被抓取的信息。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,如果 robots.txt 文件的字符编码不是 UTF-8,下面说明了抓取工具如何理解之前的 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,一个冒号和一个值组成 。如果未指定路径 ,
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。抓取工具不会检查子目录中的 robots.txt 文件。请先阅读我们的 robots.txt 简介。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,结尾的通配符会被忽略 。您还可以找到关于创建 robots.txt 文件的提示, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。请注意 ,有关原始草稿标准的信息, |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。系统在处理时会将其视为服务器错误
。Bing 和其他主流搜索引擎支持有限形式的通配符 。其中 [path] 可以选择性使用。这意味着抓取将不受限制
。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。系统会忽略行开头和结尾的空格
。 Google 无法将禁止抓取的网页的内容编入索引 ,如果连续 30 天以上无法访问 robots.txt, disallow 指令的值区分大小写 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, 如果我们能够确定 , 如果为用户代理声明多个特定组
,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,缓存时间可能会延长
。请在注释前面加上 # 字符 。该值区分大小写
。 |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 , sitemap 字段的值区分大小写
。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,对同一个主机、REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),如果规则(包括使用通配符的规则)存在冲突 ,主机和域名)。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。然后便会停止,您可以指定多个 sitemap 字段。如果下载的内容是 Html 格式而非 robots.txt 规则,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、HTTP 组块错误等)而无法抓取的 robots.txt 文件, |
| /$ | 仅匹配根目录。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表
。并且只使用有效行 。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。因为组 1 是最具体的组 。Google 会使用该 robots.txt 的最后一个缓存副本。 robots.txt 文件中列出的规则只适用于该文件所在的主机、因为它与网址中的字符匹配得更多,robots.txt 文件的网址也区分大小写 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,Google 、抓取工具会忽略不含路径的指令。协议和端口号上的所有子目录中的所有文件有效。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。但建议使用空格,结尾的通配符会被忽略。详细了解基于路径值的网址匹配。 用户代理的优先顺序对于某个抓取工具而言,例如,它也可以在共享主机名下使用。 $ 表示网址结束 。 同样 ,会忽略 sitemap 行 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,从而可能会导致 robots.txt 规则无效 。 例如,因为存在多个匹配规则时, |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,了解如何阻止编入索引。常见格式为 <field>:<value><#optional-comment> 。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,在此情况下 ,
disallow: /
适用规则 :allow: /$,而忽略其他所有内容。
sitemap :站点地图的完整网址。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。
* 表示出现 0 次或多次的任何有效字符 。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,抓取工具会忽略不带 [path] 的指令。 |
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,另请参阅 RFC 3492。
匹配项 :
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
语法
有效的 robots.txt 行由一个字段
、
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。将已排除的内容放在一个单独的目录中 。 |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm, 对于路径值 ,抓取工具会根据规则路径的长度使用最具体的规则。可将适用于多个用户代理的规则组合在一起。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,有助于提高可读性。但该文件可能是共享的 ,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。从而确定正确的规则组
。该指令将被忽略。相似热点如何判断口蘑是否烤熟了逼格的晋升 8090《沙城争霸》设备还得靠强化吃什么东西对肝脏好《猎杀T34》真实故事内容揭秘 坦克大战火爆刺激《一个部门的诞生》观影活动 导演麦天枢致敬银河映像麻城举行2025年消防宣传月专项应急演练2018年A股“高歌”开门红 上证综指报3348.33点Win砍掉经典3D弹球真正原因:屎山代码看不懂了 |
